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New Features

This version will automatically create *.tms files directly. There is no need to use the Fly! taxiway editor. It works with any version of Fly! including Fly! II. It will automatically detect the version from the “Fly! Path” setting in Preferences.

The user interface is the same as V1.0. There are a few new commands:

Display polygon outlines. Press the “L” key to toggle polygon fill.

Fillets are calculated as Bezier curves. The depth can be set from 3-10 in Preferences; the default is 5. Increasing the depth will produce smoother curves, but increase the polygon count.

Recalculate: Press the “R” key to recalculate (and redraw) all fillets, markings, and lights. The command is useful after changing the Bezier depth in Preferences.

Runway centerline vertices are constrained to runway centerlines. You cannot move a vertex at the intersection of two runways.

Taxiways aligned with runways. Drag the vertex at a runway end out. I call this a runway extension. If you attach a taxiway to end of this “extension” you get the correct markings. If the taxiway joins the extension within 5 degrees of 90 degrees, the 270-degree corner will be square.

Runway Holding Position Markings. The taxiway must intersect a runway. Right click on the taxiway and check the "Runway Hold" box. Turn on markings display and move it

by dragging.

ILS/MLS Critical Hold Markings. Right click on the taxiway and check the "Critical Hold" box. Turn on markings display and move it by dragging. It will initially appear 75’ from one end of the taxiway.

The “No Polygons (safe mode)” check box in the “Open Project” dialog is used to prevent the program from calculating and displaying fillets and associated markings. This is useful if you’ve gotten yourself in trouble at complex intersections and the program interferes with your editing. Make your changes, save, quit, and then reopen.  

To display X's on closed runways, turn off taxiway display. Right click on the runway. Check the "Closed" box.

Use the Shift key to force the “Save” menu command to be available at any time, instead of only when changes have been made.

Other than the closed runway marking, the runway markings are “eye candy” only.

Polygon triangulation errors. When these occur, they are displayed in red. They are usually degenerate polygons caused when two vertices are too close to each other. If the number intersecting segments is less than four, you might combine the vertices or move them apart. Use the “T” key to toggle the display of triangulation error polygons.

How to Install

Create a directory and put the program in it. The program will create one file in this directory: Taxiway.twp. This is a plain text file containing project information. It is used for opening existing projects created in earlier sessions with the program. The program will also create the following registry entry:

HKEY_CURRENT_USER\Software\Peter A. Jacobson\Taxiway

Setup

The first time you run the program, it will ask you where you have installed Fly!. For example: C:\Progam Files\Fly!. This path is used to find the Fly! \System and \Data directories. You can use the File menu Preferences command to change this.

Right Mouse Button Completes Object Creation

To create a taxiway or polygon, select the tool with the menu command or the toolbar button. The cursor will change from a pointer to a crosshair. Each mouse click adds a vertex. To complete the object, click the right mouse button for the last vertex. The leftmost pane of the status bar at the bottom of the window displays a message to this effect while using the tool. Polygons close automatically.

Projects

To build a new taxiway system for an airport, select the File menu New command. In the dialog box that appears, enter either the FAA or the IACO code for the airport. This will become the project name and the root name of the *.txp, *.bgr and, *.tms files that the program creates. (Leave the Load *.tms file box unchecked. It is described later.) If you wish, open and position an airport diagram (see Airport Diagrams). Draw in your taxiways and polygons. Save your work. The output files will be placed in the Fly!\Data directory or in the directory you established for output with the File menu Preferences command (see Output Directory). 

To edit an existing taxiway system for an airport, place any *.txp and *.bgr files that you have in the Fly!\Data directory. (You can also use the Fly! taxiway editor to load an existing system and then save it in the Fly!\Data directory.) The root of the file name must be the same as the FAA or IACO code you used to load the runway system. Select the File menu New command as described in the preceding paragraph. The program will automatically load and display any *.txp and *.bgr files that it finds.

You can edit your work in future sessions with the program by choosing the File menu Open command. This command displays a dialog showing the names of all the projects you have developed. 

Project information including file names and airport diagram positioning offsets is stored in a plain text file called Taxiway.twp in the directory where you installed the program. This is a plain text that you can open with any editor.

Airport Diagrams

An airport diagram greatly simplifies the process of creating or editing a taxiway system. You can simply trace your taxiways and polygons over the diagram. These World Wide Web sites can be useful for obtaining diagrams:

Aircraft Owners and Pilots Association

http://www.aopa.org/asf/taxi/index.shtml
National Association of State Aviation Officials

<http://www.nasao.org>

You will need to get the diagram into Windows bitmap format (*.bmp file). Two possibilities: 1) use a scanner or 2) take a screen shot. It is not necessary to crop the image; the program will help you with that. High resolution, gray scale images are best.

Use the Diagram menu Load command to load the diagram. The program will make a rough guess for initial position and scale. Use the Diagram menu Position command for accurate alignment. The Position command opens a modeless dialog box with controls for horizontal and vertical positioning and changing the scale. It also temporarily changes the color of runways to make them easier to distinguish against the diagram background. These controls have multipliers that, when checked, will increase the effect of using the up/down scroll arrows associated with the offset/scale edit boxes. Use the following sequence to align the diagram:

Roughly position the diagram runways under the project runways. You can do this with the edit boxes or directly in the project window by holding the left mouse button down and dragging.

Change the scale up or down as necessary. This will move the diagram, so it will probably be necessary to reposition the diagram as you establish the correct scale. 

Once the scale is correct, perform final positioning with the horizontal and vertical offset controls.

If necessary, you can rotate the project runways over the diagram with the View menu rotate commands. The initial increment is 1º, but can be changed to 0.50º or 0.25º with the File menu Preferences command. Holding the SHIFT key down while rotating the diagram forces 1º increments regardless of the Preferences setting.

Taxiway Width

Taxiway width for drawing is established with the Tools menu Taxiway Width command. The current drawing width is displayed in the status bar at the bottom of the window.

To change the width of an existing taxiway, position the mouse pointer over the taxiway, click the right mouse button, and select the Properties command from the popup menu.

Runway Centerlines

These are special taxiways (“edges” in Fly! nomenclature) used to create the markings at runway entrances from taxiways. They do not generate actual taxiways and do not appear in the scenery. For new taxiway systems, the program will automatically create one for each runway. Each end vertex will be initially inset 25’ from the runway end, but can be moved like any taxiway vertex.

Runway Centerlines should be exactly the same width as the underlying runway. 

Polygons

Polygons can be moved by positioning the mouse pointer over the polygon, holding the left button down, and dragging. Vertices can be repositioned by clicking once anywhere within the polygon to display the vertex handles. Then, simply drag the vertex to its new position. Vertices can be deleted by clicking the right mouse button over the vertex and selecting Delete Vertex from the popup menu. Vertices can be inserted by clicking the right mouse button inside the polygon, near the insertion point and selecting Insert Vertex from the popup menu.

Source and Sink

These are special vertices to indicate where the aircraft is initially positioned (source) and expects to be parked (sink). Select the tool and click on a vertex. Change it by selecting the tool and clicking on a different vertex. Delete it with the Cut command in the right click popup menu.

Optimize

You can use this command to ward off some of the problems the Fly! taxiway editor has with lines. Issue this command by typing ‘O’ or ‘o’ on the keyboard. If it modifies any vertices they will be displayed as blue dots. The dots will remain until you click the left mouse button.

The optimize command straightens lines where the subtended angle between two segments is less than 2º and greater than 0.5º. It will also attempt to create right angles where the angle falls between 88º and 92º. This command can be undone. It should not be used repetitively more than a couple of times.

The TMS file

Working with taxiways involves three file types: txp, bgr, and tms. The txp file contains descriptions of polygons. It is not used in the final scenery; all polygons are maintained in the tms file. The bgr file contains descriptions of the taxiway vertices, the connected vertices, and the source and sink vertices. It is used in the final scenery, but only for source and sink positions and (probably) to taxi dynamic aircraft.

The tms file consists of polygons of different types and taxiway lighting descriptions. The polygons consist of pavement polygons, mostly tessellated, edge and centerline markings, and the lighting system. You can examine this file in the taxiway.exe program. Select the File menu New command, enter the FAA or IACO code of a project that you have the tms file for, and check the Load *.tms box. You won’t be able to edit what you see, but this how the system will appear in the scenery. Use the View menu commands to show the lighting system and the taxiway markings.

One item of interest is the "grid". My guess is that Fly! uses this grid for visibility of the taxiway system.

Colors

The colors of runways, taxiways, and polygons are initially set to gray by the program. However, when drawn on top of a grayscale bitmap, it may be difficult to distinguish features.  Use the File menu Preferences command to change the colors of these features to whatever you wish for greater contrast.

Output Directory

Normally, the *.tms and *.bgr files would be placed in the Fly! \Data directory during development and perhaps ultimately. Eventually they may be packaged into an *.epd file alone or along with other files. There are situations where it may be convenient to use a working directory other than \Data for the Fly! taxiway editor. 

If a taxiway system already exists for an airport and you are replacing it, you must specify a complete path to the Fly! taxiway editor “load” command. Otherwise, the editor will load the version already in the Fly! database. However, the Fly! editor has difficulty parsing paths that contain spaces as in “Fly! 2K” or “C:\Program Files”. Changing the output directory to something like “D:\work” can simply the interaction between this editor and Fly!’s. Use the File menu Preferences command to change the program’s output directory; where it stores the *.txp and *.bgr files.

Details

As you draw taxiways that cross other taxiways or runway centerlines, the program automatically creates a vertex at all intersections. The intersections are created after you finish with the tool (click the right mouse button). If the intersection creates a new segment that is below a specific threshold length (25’), that section is deleted. The threshold can be controlled with the File menu Preferences command.

To connect a taxiway to a point along an existing taxiway (such as runway centerline), begin or finish the drawing as near as possible to the center of the existing taxiway (or runway centerline). The program will “snap” the new segment to the existing one, creating a new vertex at that point. 

To connect a taxiway to the endpoint of an existing taxiway (such as runway centerline), begin or finish the drawing as near as possible to the endpoint of the existing taxiway (or runway centerline). The program will “snap” the endpoint of the new segment to the vertex of the existing one. 

Legal

This program is freeware. Enjoy. However, I hold the copyright and control distribution rights, commercial or otherwise. You may make all the copies you want. You may freely give this program to anyone you want. You may not distribute it by any commercial means whatsoever, including by not limited to magnetic or optical media, electronic or Internet based. You may not upload this program to any Internet repository without my express written permission. And so on…

This program comes without any warranty whatsoever. You got what you paid for.

Contact

Report any problems you encounter to:

pjacobson@amexol.net
Please do not post my name or email address to any Internet newsgroup, list server, or other open forum.

Thanks,

Peter A. Jacobson

